Symfony projesinin başındaki Fabien Potencier, Twitter hesabından Kasım 2017’de yayınlanacak olan majör versiyon Symfony 4’ün, PHP 7 ile çalışacağını duyurdu.

Laravel ise PHP 5 desteğini daha yakın zamanda bırakacak. Laravel’in yaratıcısı Taylor Otwell ise Haziran 2017’de yayınlanacak Laravel 5.5’in en az PHP 7 ile çalışabileceğini açıkladı.

Taylor, birkaç konuşmasında skalar ve return type hint kullanımını pek sevmediğini söylemişti. Bu nedenle PHP 7 ile gelen bu özellikleri Laravel kod tabanında pek göremeyebiliriz. Bunun yerine, ?? ile ifade edilen null birleşim operatörünü sıkça görmemiz olası.

Geçtiğimiz günlerde yayınladığımız yazıda, Packagist’teki paketlerin sadece %3’ünün PHP 7 gerektirdiğini belirtmiştik. Symfony ve Laravel’in yeni sürümlerinde PHP 7 ve üzerine ihtiyaç duyacak olması, diğer geliştiricilere de öncülük edecek, Packagist’teki bu oran artacaktır.

Küçük bir not: WordPress’in minimum gereksinimi hâlâ PHP 5.2.  😕